import re
regex = re.compile(r"((?:[ ]|^|[^\d\.\:\-\r\n$£])((?:1[0-9]|2[0-4]|0?[1-9]|00|one|two|three|four|five|six|seven|eight|nine|ten|eleven|twelve)[ ]?[\:\. ]?[ ]?(?:[0-5][0-9]|fifteen|thirty|fou?rty ?five)(?:[ ]?(?:am|pm)|[ ]?o\'?[ ]?clock))(?:\b|$|,\b)|(?:[ ]|^|[^\d\.\:\-\r\n$£])(((?:1[0-9]|2[0-4]|0?[1-9]|00|one|two|three|four|five|six|seven|eight|nine|ten|eleven|twelve)(?:[ ]?(?:am|pm))|[ ]?o\'?[ ]?clock))(?:\b|$|,\b)|(?:[ ]|^|[^\d\.\:\-\r\n$£])((?:1[0-9]|2[0-4]|0?[1-9]|00|one|two|three|four|five|six|seven|eight|nine|ten|eleven|twelve)[ ]?[\:\. ][ ]?(?:[0-5][0-9]|fifteen|thirty|fou?rty ?five)(?:\b|$|,\b))|(?:[ ]|^|[^\d\.\:\-\r\n$£])((?:1[0-9]|2[0-4]|0?[1-9]|00) ?(?:PS?T|GMT|∆USA|∆US|ET|BST|∆UK|UK ?[Tt]ime|[Ee]astern [Tt]ime|[Pp]acific [Tt]ime|[Cc]entral [Tt]ime|∆UTC|ACDT|ACST|ACT|ACT|ADT|AEDT|AEST|AFT|AKDT|AKST|AMST|AMT|AMT|ART|AST|AST|AWDT|AWST|AZOST|AZT|BDT|BDT|BIOT|BRST|BRT|BST|BST|BST|BTT|CCT|CDT|CDT|CEDT|CEST|CET|CHADT|CHAST|CHOT|ChST|CHUT|CIST|CIT|CKT|CLST|CLT|COT|CST|CST|CST|CST|CST|CT|CVT|CWST|CXT|DAVT|DDUT|DFT|EASST|ECT|ECT|EDT|EEDT|EEST|EET|EGST|EGT|EIT|EST|EST|FET|FJT|FKST|FKST|FKT|FNT|GALT|GAMT|GFT|GILT|GIT|GMT|GST|GST|GYT|HADT|HAEC|HAST|HKT|HMT|HOVT|HST|IBST|ICT|IDT|IRDT|IRKT|IRST|IST|IST|IST|JST|KGT|KOST|KRAT|KST|LHST|LHST|LINT|MAGT|MART|MAWT|MDT|MET|MEST|MHT|MIST|MMT|MSK|MST|MST|MST|MUT|MVT|MYT|NCT|NDT|NFT|NPT|NST|NT|NUT|NZDT|NZST|OMST|ORAT|PDT|PETT|PGT|PHOT|PKT|PMDT|PMST|PONT|PST|PST|PYST|PYT|RET|ROTT|SAKT|SAMT|SAST|SBT|SCT|SGT|SLST|SRET|SRT|SST|SST|SYOT|TAHT|THA|TFT|TJT|TKT|TLT|TMT|TOT|TVT|ULAT|USZ1|UYST|UYT|UZT|VET|VLAT|VOLT|VOST|VUT|WAKT|WAST|WAT|WEDT|WEST|WET|WST|YAKT))\b)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("4pm\n"
"12:00\n"
"4 CET\n"
"17 UK Time\n\n"
"1200pm\n\n"
"12pm\n"
"14.00\n"
"15.00pm\n\n"
" 33\n\n"
"4pm\n"
"4 pm\n"
" 4:30pm\n"
"3/5/7\n\n"
"Mon\n"
"Tue\n"
"Next Tue ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")