#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!version-\d+\.\d).*12\.3.*$"
Local $sString = "bugfix-ISSUE-123-some-details-version-12.3" & @CRLF & _
"ISSUE-1234-some-other-details-version-12.3" & @CRLF & _
"bugfix-12.3" & @CRLF & _
"bugfix2-12.3" & @CRLF & _
"12.3stuff" & @CRLF & _
"stu12.3ff" & @CRLF & _
"" & @CRLF & _
"// match everything above, but don't match anything from below" & @CRLF & _
"" & @CRLF & _
"master" & @CRLF & _
"version-12.3" & @CRLF & _
"version-3.21" & @CRLF & _
"some-other-branch" & @CRLF & _
"bugfix-3.21" & @CRLF & _
"test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")