$re = '/\.|( +)/';
$str = 'x.i.x.m x.i.x.m.ng(ing)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);