$re = '/^\d{1,6}(\.\d{1,2})?$^0$|^[1-9]{1}\.[0-9]{1}$|^10\.0$/';
$str = '10.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);