const regex = /^[0-9](?:\.[0-9]{1,2})?$|^10(?:\.00?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9](?:\\.[0-9]{1,2})?$|^10(?:\\.00?)?$', 'gm')
const str = `0
0.1
0.12
0.123
10.0
10.00
9.99
1.12
2.34
11.1
1
2
3
4
5
6
7
8
9
1.1
2.12
3.32
4.45
5.67
6.98
7.12
8.3
9.56
10
1.1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}