re = /(^|[^a-z0-9])(ECU|HVAC|ABS|ESC|EGR|ADAS|HEV|HMI)(?=$|[^a-z0-9])/i
str = 'abs/esc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end