package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)му(жи|да)ка`)
var str = `мужика
мудака`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}