$re = '/(\w+=\\\\"[\w:\/.]+\\\\")/';
$str = ' <a class=\\"direct_link\\" rel=\\"nofollow\\" target=\\"_blank\\" href=\\"http://google.com\\">link text</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);