$re = '/\b1\b((?:(?!\b1\b).)*?)
\b2\b((?:(?!\b2\b).)*?)
\b3\b((?:(?!\b3\b).)*?)
\b4\b((?:(?!\b4\b).)*?)
\b5\b((?:(?!\b5\b).)*?)
\b6\b((?:(?!\b6\b).)*?)
\b7\b((?:(?!\b7\b).)*?)
\b8\b((?:(?!\b8\b).)*?)
\b9\b((?:(?!\b9\b).)*?)
\b10\b((?:(?!\b10\b).)*?)/mxs';
$str = 'CHAPTER 1
1 He loves Mary, 2 and Mary loves him. 3 They have three kids and 12 chickens. 4 Their address is 1234 Applewood Dr. and 5 they\'ve lived there for 10 years.
6 In their 11th year in the house, 7 Mary and Greg planted 15 tulips, 8 12 rose bushes, and 9 three apple trees. 10 Everything they had burned to the ground.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);