$re = '/(?:\G(?!\A)|\[)[^][\d]*\K\d+(?:\.\d+)?(?=[^][]*])/m';
$str = 'I have the following expression [+₪7.00 and 98], I wish to extract only 7.00 or 7.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);