$re = '/\d+(\s|-)?\w*$/m';
$str = '1st street 25
1st street 25 a
1st street 25b
1st street 25-ab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);