$re = '/(?!tea)t[\w ]*a/m';
$str = 'tea
teea
t__ 02 a
tsds
asda
thiworlda';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);