package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(1?(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\.){3}(1?[0-9]{1,2}|2[0-4][0-9]|25[0-5])\b`)
var str = `192.168.1.1
127.0.0.1
256.548.0.1
255.255.255.0
192.168.123.1
0.1
123.4
19864.684.1
123.123.123
123.123.260.123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}