#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)<div class="(.*?) video-item">(.*?)href="([^"]*)"(.*?)data-get-thumbs-url="([^"]*)"(.*?)alt="([^"]*)"(.*?)src='([^']*)'(.*?)<div class="timer hidden-xs">(\s*)<p>([0-9]*)(.*?)<\/p><\/div>(.*?)<div class="description">(\s*)<p>(.*?)<\/p>(.*?)<p class="title-video">(.*?)<\/p>(.*?)<div class="infos-video">(.*?)<p>Le ([0-9][0-9])\/([0-9][0-9])\/([0-9][0-9][0-9][0-9])<\/p>(\s*)<p>([0-9 ]*?)vues<\/p>(.*?)<\/div>(.*?)<div class="cat-video">(\s*)(.*?)(\s*)<\/div>(\s*?)<\/div>"
Local $sString = "" & @CRLF & _
" " & @CRLF & _
" <div class="col-md-3 col-sm-4 col-xs-6 video-item">" & @CRLF & _
"" & @CRLF & _
" <a target="_blank" data-popunder-enabled href="/videos/show/1983/sandrine-teste-la-double.html">" & @CRLF & _
" <div class="thumb-video">" & @CRLF & _
" " & @CRLF & _
" <img class="videoThumb"" & @CRLF & _
" data-get-thumbs-url="/video/1983/thumbnails_262x196.json"" & @CRLF & _
" alt="Double pénétration, Double vaginale, Sodomie"" & @CRLF & _
" src='http://m.tv2.cdn.jetm-tech.net/cache/4a/c5/4ac5ff7ae42612bfc68139740700ea0c.jpg'" & @CRLF & _
" />" & @CRLF & _
" " & @CRLF & _
" <div class="timer hidden-xs"> <p>47 min</p></div>" & @CRLF & _
"" & @CRLF & _
" <div class="description">" & @CRLF & _
" <p>Notre équipe retrouve Sandrine devant le château de Blois pour constater, une fois de plus, que cette timide historienne de 31ans est une sacrée chaudasse ! " & @CRLF & _
"…</p>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <p class="title-video"> Sandrine teste la double !</p>" & @CRLF & _
" <div class="infos-video">" & @CRLF & _
" <p>Le 12/10/2015</p>" & @CRLF & _
" <p>1 876 156 vues</p>" & @CRLF & _
" </div>" & @CRLF & _
" </a>" & @CRLF & _
" <div class="cat-video">" & @CRLF & _
" <p>Catégories : <a href="/tag/1/double-penetration.html">Double pénétration</a>, <a href="/tag/2/double-vaginale.html">Double vaginale</a>, <a href="/tag/8/sodomie.html">Sodomie</a></p>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" <div class="col-md-3 col-sm-4 col-xs-6 video-item">" & @CRLF & _
"" & @CRLF & _
" <a target="_blank" data-popunder-enabled href="/videos/show/1982/soizic-passe-un-entretien-dembauche.html">" & @CRLF & _
" <div class="thumb-video">" & @CRLF & _
" " & @CRLF & _
" <img class="videoThumb"" & @CRLF & _
" data-get-thumbs-url="/video/1982/thumbnails_262x196.json"" & @CRLF & _
" alt="Cougar, Scénario, Sodomie"" & @CRLF & _
" src='http://m.tv2.cdn.jetm-tech.net/cache/cc/e5/cce55a7502d51aaefc049ee83334653c.jpg'" & @CRLF & _
" />" & @CRLF & _
" " & @CRLF & _
" <div class="timer hidden-xs"> <p>30 min</p></div>" & @CRLF & _
"" & @CRLF & _
" <div class="description">" & @CRLF & _
" <p>Quand Soizic, 40ans, de Saint-Malo, et l'ami Rick se font un petit plan un brin pervers..." & @CRLF & _
"Pour voir ses vidéos, mettez Soizic dans la recherche." & @CRLF & _
"Parlez en …</p>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <p class="title-video"> Soizic passe un entretien d'embauche !</p>" & @CRLF & _
" <div class="infos-video">" & @CRLF & _
" <p>Le 11/10/2015</p>" & @CRLF & _
" <p>1 882 538 vues</p>" & @CRLF & _
" </div>" & @CRLF & _
" </a>" & @CRLF & _
" <div class="cat-video">" & @CRLF & _
" <p>Catégories : <a href="/tag/23/cougar.html">Cougar</a>, <a href="/tag/56/scenario.html">Scénario</a>, <a href="/tag/8/sodomie.html">Sodomie</a></p>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" <div class="col-md-3 col-sm-4 col-xs-6 video-item">" & @CRLF & _
"" & @CRLF & _
" <a target="_blank" data-popunder-enabled href="/videos/show/1981/lola-se-libere.html">" & @CRLF & _
" <div class="thumb-video">" & @CRLF & _
" " & @CRLF & _
" <img class="videoThumb"" & @CRLF & _
" data-get-thumbs-url="/video/1981/thumbnails_262x196.json"" & @CRLF & _
" alt="Double pénétration, Sodomie, Trio HHF"" & @CRLF & _
" src='http://m.tv2.cdn.jetm-tech.net/cache/f3/5b/f35b23b16f81588dda16702cec5ef284.jpg'" & @CRLF & _
" />" & @CRLF & _
" " & @CRLF & _
" <div class="timer hidden-xs"> <p>42 min</p></div>" & @CRLF & _
"" & @CRLF & _
" <div class="description">" & @CRLF & _
" <p>Sa première vidéo a eu de telles vertus thérapeutiques que Lola surmonte désormais tous ses complexes et va même jusqu'à nous entraîner chez un de ses nouveaux…</p>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <p class="title-video"> Lola se libère !</p>" & @CRLF & _
" <div class="infos-video">" & @CRLF & _
" <p>Le 10/10/2015</p>" & @CRLF & _
" <p>1 717 096 vues</p>" & @CRLF & _
" </div>" & @CRLF & _
" </a>" & @CRLF & _
" <div class="cat-video">" & @CRLF & _
" <p>Catégories : <a href="/tag/1/double-penetration.html">Double pénétration</a>, <a href="/tag/8/sodomie.html">Sodomie</a>, <a href="/tag/21/trio-hhf.html">Trio HHF</a></p>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")