import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?>[^()]|(?R))*\\)";
final String string = "__DATA__\n"
+ "always @(posedge clk or negedge rst_n)\n"
+ "if(!rst_n)begin\n"
+ " d1 <= 0; //perl_comment_4\n"
+ " //perl_comment_5\n"
+ " d2 <= 1 //perl_comment_6\n"
+ " + 2;\n"
+ " end\n"
+ "else if( d3 <= d4 && ( d5 <= 3 ) ) begin\n"
+ " d6 <= d7 +\n"
+ " (d8 <= d9 ? 1 : 0);\n"
+ " //perl_comment_7\n"
+ " d10 <= d11 <=\n"
+ " d12\n"
+ " + d13\n"
+ " <= d14 ? 1 : 0;\n"
+ " end";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}