re = /\[[^\]]*]$/m
str = 'Front SHD Trip CLEAR OBSTRUCTION BEFORE CONTINUING [Table Position = 0mmFwd]
Front SHD Trip CLEAR OBSTRUCTION BEFORE CONTINUING [Table Position = 563mmFwd]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end