import re
regex = re.compile(r"^(?!BG|GB|KN|NK|NT|TN|ZZ)[^DFIQUV][^DFIQUVo][0-9]{6}[ABCD]$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("BG283902A\n"
"AD283902A\n"
"AO283902A\n"
"AA283902Z\n"
"AA283902A")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")