$re = '/((?:.*?)\.png)((?1))((?1))((?1))((?1))((?1))((?1))((?1))(.*)/';
$str = 'PEKKACard.pngGolemCard.pngFreezeCard.pngBombTowerCard.pngHogRiderCard.pngGiantCard.pngBomberCard.pngElixirCollectorCard.pngplease';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);