$re = '/^([^=\s]+)\s*=\s*([^;\r\n]+)(?<!\s)/';
$str = 'ServiceType = 1 ; SERVICE_KERNEL_DRIVER';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);