#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)[\n\r]([\d:,]+\s-->\s[\d:,]+)[\n](.+(?:[\n]*[^\d|^\n]+)*)"
Local $sString = "0" & @CRLF & _
"00:00:00,000 --> 00:00:00,000" & @CRLF & _
"Hello world!" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"00:00:00,000 --> 00:00:00,000" & @CRLF & _
"Hello world!" & @CRLF & _
"This is my new world." & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:00:00,000 --> 00:00:00,000" & @CRLF & _
"Hello guys!" & @CRLF & _
"Hello guys!" & @CRLF & _
"Hello guys!" & @CRLF & _
"Hello guys!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")