package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+(?:-\w+)*|\$[\d.]+|\S+`)
var str = `half-life`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}