#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!FONT|2000)[^"\n]*"\K(?!\s+")([^"]+)"
Local $sString = "/*" & @CRLF & _
" * PROJECT: Solitaire by Daniel "EmuandCo" Reimer" & @CRLF & _
" * LICENSE: Freeware, permission to use under Public Domain" & @CRLF & _
" * FILE: base/applications/games/solitaire/lang/en-US.rc" & @CRLF & _
" * PURPOSE: English Language File for Solitaire" & @CRLF & _
" * PROGRAMMERS: Daniel "EmuandCo" Reimer (reimer.daniel@freenet.de)" & @CRLF & _
" */" & @CRLF & _
"IDS_NO_SUCH_FILE "FIND: %s: Plik nie został znaleziony\n", 6, 15, 5" & @CRLF & _
"LTEXT_BLANK " "" & @CRLF & _
"FONT 8, "Arial"" & @CRLF & _
"0 "Some text"" & @CRLF & _
"1 " Some text "" & @CRLF & _
"2000, "Lautus Theme"" & @CRLF & _
"2001, "Lautus Theme" "ffafa"" & @CRLF & _
"MENU IDR_MENU_SCIENTIFIC_1" & @CRLF & _
"FONT 8, "MS Shell Dlg", 0, 0, 0x1" & @CRLF & _
"BEGIN" & @CRLF & _
" GROUPBOX "", IDC_STATIC, 5 ,14, 141, 20" & @CRLF & _
" LTEXT "Plik ten może być używany przez system operacyjny lub przez\n\" & @CRLF & _
"inną aplikację. Modyfikacja tego pliku może spowodować uszkodzenie twojego\n\" & @CRLF & _
"systemu lub uczynić go mniej funkcjonalnym.\n\n\" & @CRLF & _
"Czy na pewno chcesz otworzyć ten plik?", IDC_STATIC, 35, 5, 230, 60" & @CRLF & _
" DEFPUSHBUTTON "Tak", IDYES, 125, 55, 50, 14" & @CRLF & _
"IDS_USAGE "FIND: Wyświetla wszystkie linie danego pliku, zawierające szukany ciąg znaków.\n\n\" & @CRLF & _
" FIND [ /C ] [ /I ] [ /N ] [ /V ] ""ciąg znaków"" [ plik... ]\n\" & @CRLF & _
" /I Ignoruje wielkość liter"" & @CRLF & _
" IDS_NO_SUCH_FILE "FIND: %s: Plik nie został znaleziony\n""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")