import re
regex = re.compile(r"^(?!FONT|2000|\s*\*)[^\"\n]*\"\K(?!\s*(?:\"|\n))([^\"]+)", flags=re.MULTILINE)
test_str = ("/*\n"
" * PROJECT: Solitaire by Daniel \"EmuandCo\" Reimer\n"
" * LICENSE: Freeware, permission to use under Public Domain\n"
" * FILE: base/applications/games/solitaire/lang/en-US.rc\n"
" * PURPOSE: English Language File for Solitaire\n"
" * PROGRAMMERS: Daniel \"EmuandCo\" Reimer (reimer.daniel@freenet.de)\n"
" */\n"
"IDS_NO_SUCH_FILE \"FIND: %s: Plik nie został znaleziony\\n\", 6, 15, 5\n"
"LTEXT_BLANK \" \"\n"
"FONT 8, \"Arial\"\n"
"0 \"Some text\"\n"
"1 \" Some text \"\n"
"2000, \"Lautus Theme\"\n"
"2001, \"Lautus Theme\" \"ffafa\"\n"
"MENU IDR_MENU_SCIENTIFIC_1\n"
"FONT 8, \"MS Shell Dlg\", 0, 0, 0x1\n"
"BEGIN\n"
" GROUPBOX \"\", IDC_STATIC, 5 ,14, 141, 20\n"
" LTEXT \"Plik ten może być używany przez system operacyjny lub przez\\n\\\n"
"inną aplikację. Modyfikacja tego pliku może spowodować uszkodzenie twojego\\n\\\n"
"systemu lub uczynić go mniej funkcjonalnym.\\n\\n\\\n"
"Czy na pewno chcesz otworzyć ten plik?\", IDC_STATIC, 35, 5, 230, 60\n"
" DEFPUSHBUTTON \"Tak\", IDYES, 125, 55, 50, 14\n"
"IDS_USAGE \"FIND: Wyświetla wszystkie linie danego pliku, zawierające szukany ciąg znaków.\\n\\n\\\n"
" FIND [ /C ] [ /I ] [ /N ] [ /V ] \"\"ciąg znaków\"\" [ plik... ]\\n\\\n"
" /I Ignoruje wielkość liter\"\n"
" IDS_NO_SUCH_FILE \"FIND: %s: Plik nie został znaleziony\\n\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")