#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[NMS]\w+\-\w*BASE\w*\.AD\.DTI"
Local $sString = "MAVM-WLBASE1a.ad.dti." & @CRLF & _
"MAVM-WLBASE2a.ad.dti." & @CRLF & _
"MAVM-WLBASE3a.ad.dti." & @CRLF & _
"MAVM-WLBASE4a.ad.dti." & @CRLF & _
"MAVM-WLBASE5a.ad.dti." & @CRLF & _
"NJ-BASEQA2015.ad.dti." & @CRLF & _
"NJVM-BASEQA2014.ad.dti." & @CRLF & _
"NJVM-WLBASE6b.ad.dti." & @CRLF & _
"NJVM-WLBASE7a.ad.dti." & @CRLF & _
"NY2-BASEQA.ad.dti." & @CRLF & _
"NY2-DW5BASEQA01.ad.dti." & @CRLF & _
"SHVM-WLBASE1A.ad.dti." & @CRLF & _
"NJ-ODEV2015.ad.dti." & @CRLF & _
"NJ-ODEV2015b.ad.dti." & @CRLF & _
"NJVM-ODEV2014.ad.dti." & @CRLF & _
"NY2-ODEV2017.ad.dti." & @CRLF & _
"SH-ODEV2017.ad.dti." & @CRLF & _
"MOVM-WL12C.ad.dti." & @CRLF & _
"NJ-PASWL12c01.ad.dti." & @CRLF & _
"NJ-WL12cSVT01.ad.dti." & @CRLF & _
"NJVM-WL12CUST1.ad.dti." & @CRLF & _
"NJVM-wl12cust2.ad.dti." & @CRLF & _
"njvm-wl12cust4.ad.dti." & @CRLF & _
"njvm-wl12x64j7a.ad.dti." & @CRLF & _
"NY2-WL12asp01.ad.dti." & @CRLF & _
"NY2-WL12ASP02.ad.dti." & @CRLF & _
"NY2-WL12ASP03.ad.dti." & @CRLF & _
"NY2-WL12ASP04.ad.dti." & @CRLF & _
"SH-AutoITWL12.ad.dti." & @CRLF & _
"SH-PASWL12c02.ad.dti." & @CRLF & _
"SHVM-WL12-RE.ad.dti." & @CRLF & _
"SHVM-WL12CUST3.ad.dti." & @CRLF & _
"ASP-WL1213INT01.asp.ad.dti." & @CRLF & _
"ASP-WL12CEXT5.asp.ad.dti." & @CRLF & _
"ASPVM-WL12c10.asp.ad.dti." & @CRLF & _
"ASPVM-WL12c8.asp.ad.dti." & @CRLF & _
"ASPVM-WL12c9.asp.ad.dti." & @CRLF & _
"LT-MPROEKT.ad.dti." & @CRLF & _
"LT-jpo01.ad.dti" & @CRLF & _
"LT-jpo01.adXdti"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")