package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d[1-9]+\-\d[1-9]+\-\d[1-9]+\s+\d[1-9]\.\d[1-9]+\w+\s+&+\w+\d\s+\w+\s+\w+\s+\d+`)
var str = `32-99-15 13.62A &AD4 USFR EN 00*`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}