re = /(https?:\/\/(?:(?!https?:\/\/).)*)/
str = 'https://00e9e64bac25fa94607-apidata.googleusercontent.com/download/redacted?qk=AD5uMEnaGx-JIkLyJmEF7IjjU8bQfv_hZTkH_KOeaGZySsQCmdSPZEPHHAzUaUkcDAOZghttps://console.developers.google.com/project/reducted/?authuser=1\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end