$re = '/\((?="[^;\s])/';
$str = 'SetData("ABCDEFG");
a = "("; ';
$subst = "(L";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;