using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\#rn\:(?!msg)";
string input = @"#rn:abc -> matches
#rn:msh -> matches
#rn:xy -> matches
#rn:defg -> matches
#rn:msg - does not match";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}