# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*on\s*/\n/gim;t' <<< "Syed Arafath on Jan 7, 2015
Capt.KSD on Dec 30, 2014
chakradharalasakani on Dec 29, 2014
mitesh0123 on Dec 18, 2014
Aparajita61@yahoo.in on Dec 3, 2014
123chetan on Oct 28, 2014"