$re = '/([^\[\]\s]+)(?![^\[]*\])/i';
$str = '[Hi!]My name is John.
My name is John [I suppose]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);