$re = '/^ +| +$|( ) +/m';
$str = ' this is my string
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;