$re = '/\b[a-zA-Z]*\d+?/';
$str = 'lol these are words but i1 i2 i3 matches e1dsadij cause they match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);