re = /@^([\w-\.]+)@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([\w-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)$/
str = 'axaxsa@yaho.com '
# Print the match result
str.match(re) do |match|
puts match.to_s
end