$re = '/(\d{2}[.]\d{2}[.]\d{4})/';
$str = '//Beginn
13.11.1999 //erster Tag
18.14.1999 //letzter Tag
//Ende';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);