$re = '/(?:^| +)(\w+ ?\w*) *: +/i';
$str = 'Device: ILO 5 Firmware Version : 2:33 Firmware date : 10-10-2020';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);