import Foundation
let pattern = #"(?<=^.*?[?!.].*?[?!.]).+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque faucibus justo id metus fringilla, nec bibendum sem vulputate. Vivamus nec ex ut risus luctus tincidunt ac et lacus. Mauris molestie laoreet tortor non fermentum. Vestibulum tincidunt nulla quis feugiat pharetra. Donec non posuere purus. Donec mattis convallis augue, ut semper justo varius vel. Proin tristique dui ac elit tempor molestie. Nulla nec ultricies nunc."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)