re = /(\w+)(:|<|>)(.+?)(?:,)/
str = 'activitytype:Dev,seniority:Senior >96 month,skill:c#,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end