package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<server url="([^"]+).*?name="([^"]+).*?cc="FR.*?sponsor="([^"]+)`)
var str = `<server url="http://176.109.165.21/speedtest/upload.php" lat="50.8500" lon="16.4833" name="Swidnica" country="Poland" cc="PO" sponsor="Dolnet Group sp. z o. o." id="6174" url2="http://ossto.tk/speedtest/upload.php"/><server url="http://speedtest-01.cloudconnx.net/speedtest/upload.php" lat="50.7700" lon="0.2800" name="Eastbourne" country="Great Britain" cc="GB" sponsor="CloudConnX" id="3829" url2="http://speedtest-02.cloudconnx.net/speedtest/upload.php" host="speedtest-01.cloudconnx.net:8080"/><server url="http://speedtesta.isleofwightspeedtest.com/speedtest/upload.aspx" lat="50.7667" lon="-1.3000" name="Cowes" country="Great Britain" cc="GB" sponsor="WightFibre" id="2886" url2="http://speedtestb.isleofwightspeedtest.com/speedtest/upload.aspx" host="speedtesta.isleofwightspeedtest.com:8080"/><server url="http://speedtest.hillcom.de/upload.php" lat="50.7511" lon="9.2711" name="Alsfeld" country="Germany" cc="DE" sponsor="HillCom Solutions" id="6599" url2="http://speedcheck.hillcom.de/upload.php" host="speedtest.hillcom.de:8080"/><server url="http://speedtest-lk.airbites.net.ua/speedtest/upload.php" lat="50.7500" lon="25.3333" name="Lutsk" country="Ukraine" cc="UA" sponsor="Airbites Ukraine" id="3811" url2="http://speedtest-lutsk.airbites.net.ua/speedtest/upload.php" host="speedtest-lk.airbites.net.ua:8080"/><server url="http://web.itt.net.ua/test/speedtest/upload.php" lat="50.7500" lon="25.3333" name="Lutsk" country="Ukraine" cc="UA" sponsor="Datagroup Volyn" id="2862" host="web.itt.net.ua:8080"/><server url="http://1.bournemouth.speedtest.c4l.co.uk/speedtest/upload.php" lat="50.7300" lon="-1.8800" name="Bournemouth" country="Great Britain" cc="GB" sponsor="CONNEXIONS4LONDON Ltd" id="2153" url2="http://2.bournemouth.speedtest.c4l.co.uk/speedtest/upload.php" host="1.bournemouth.speedtest.c4l.co.uk:8080"/><server url="http://speedtest.derkom.net.pl/speedtest/upload.php" lat="50.7247" lon="23.2606" name="Zamosc" country="Poland" cc="PL" sponsor="DERKOM SP. J." id="2911" url2="http://speedtest2.derkom.net.pl/speedtest/upload.php" host="speedtest.derkom.net.pl:8080"/><server url="http://test1.gtnet.pl/speedtest/upload.php" lat="50.7247" lon="23.2606" name="Zamosc" country="Poland" cc="PL" sponsor="GTnet sp.j." id="2365" url2="http://test2.gtnet.pl/speedtest/upload.php"/><server url="http://speed1.masconcable.ca/speedtest/upload.php" lat="50.7022" lon="-119.2722" name="Salmon Arm, BC" country="Canada" cc="CA" sponsor="Mascon Cable Systems Inc" id="3581" url2="http://speed2.masconcable.ca/speedtest/upload.php" host="speedtest.masconcable.ca:8080"/><server url="http://rbx-fr.verelox.com/speedtest/upload.php" lat="50.7000" lon="3.1700" name="Roubaix" country="France" cc="FR" sponsor="Verelox" id="6145" url2="http://rbx-fr.verelox.com/speedtest/upload.php" host="rbx-fr.verelox.com:8080"/><server url="http://speedtestnet.kubofonista.net/speedtest/upload.php" lat="50.6900" lon="3.1817" name="Roubaix" country="France" cc="FR" sponsor="Kubofonista Network" id="3770"/><server url="http://speedtest.eplay-tv.de/speedtest/upload.php" lat="50.6900" lon="3.1817" name="Roubaix" country="France" cc="FR" sponsor="ePlay TV" id="2951" url2="http://www.eplay-tv.eu/speedtest/speedtest/upload.php" host="speedtest.eplay-tv.de:8080"/><server url="http://speedtest1.proof.ovh.net/speedtest/upload.php" lat="50.6900" lon="3.1817" name="Roubaix" country="France" cc="FR" sponsor="OVH" id="1889" url2="http://speedtest2.proof.ovh.net/speedtest/upload.php"/><server url="http://speedtest.newone.de/speedtest/upload.php" lat="50.6872" lon="10.9142" name="Ilmenau" country="Germany" cc="DE" sponsor="Newone" id="3823" url2="http://speedtest.ilmenau.net/speedtest/upload.php" host="speedtest.newone.de:8080"/><server url="http://speedtest.sipr.ucl.ac.be/speedtest/upload.php" lat="50.6678" lon="4.6117" name="Louvain-La-Neuve" country="Belgium" cc="BE" sponsor="Universite Catholique de Louvain" id="4812" url2="http://speedtest-ucl.dyndns.org/speedtest/upload.php" host="speedtest.sipr.ucl.ac.be:8080"/><server url="http://speedtest.verixi.net/mini/speedtest/upload.php" lat="50.6678" lon="4.6117" name="Louvain-La-Neuve" country="Belgium" cc="BE" sponsor="Verixi SPRL" id="4904" url2="http://speedtest2.verixi.net/mini/speedtest/upload.php"/><server url="http://speedtest.po.opole.pl/speedtest/upload.php" lat="50.6667" lon="17.9333" name="Opole" country="Poland" cc="PL" sponsor="Opole Univ of Technology" id="1165" url2="http://217.173.198.235/speedtest/upload.php" host="speedtest.po.opole.pl:8080"/><server url="http://speedtest-l1.nemicom.ua/upload.php" lat="50.6439" lon="29.9339" name="Borodianka" country="Ukraine" cc="UA" sponsor="Nemicom" id="5767" url2="http://speedtest-l2.nemicom.ua/upload.php" host="speedtest.nemicom.ua:8080"/><server url="http://www.prolink.net.ua/test/speedtest/upload.php" lat="50.6439" lon="29.9339" name="Borodianka" country="Ukraine" cc="UA" sponsor="PROLINK LLC" id="5535" host="www.prolink.net.ua:8080"/><server url="http://speedtest.voo.be/speedtest/upload.php" lat="50.6333" lon="5.5667" name="Liege" country="Belgium" cc="BE" sponsor="VOO" id="2419" host="speedtest.voo.be:8080"/><server url="http://st.1ptb.com/speedtest/upload.php" lat="50.6333" lon="38.7000" name="Alexeyevka" country="Russian Federation" cc="RU" sponsor="1 Petabyte Ltd." id="4582" url2="http://93.170.215.20/speedtest/upload.php"/><server url="http://spdt1.comanet.cz/speedtest/upload.php" lat="50.6278" lon="15.6103" name="Vrchlabi" country="Czech Republic" cc="CZ" sponsor="Ing. Leos Janouch" id="4507" url2="http://spdt2.comanet.cz/speedtest/upload.php" host="spdt1.comanet.cz:8080"/><server url="http://speedtest.ate.info/speedtest/upload.php" lat="50.6233" lon="3.1450" name="Villeneuve-d'Ascq" country="France" cc="FR" sponsor="ATE" id="3572" url2="http://speedtest02.ate.info/speedtest/upload.php" host="speedtest.ate.info:8080"/><server url="http://speedtest.itbusiness.cz/upload.php" lat="50.6167" lon="15.1667" name="Turnov" country="Czech Republic" cc="CZ" sponsor="ITBUSINESS s.r.o." id="6288" url2="http://speedtest.itbss.cz/upload.php" host="185.15.111.74:8080"/><server url="http://test.campus-rv.net/speedtest/upload.php" lat="50.6167" lon="26.2500" name="Rivne" country="Ukraine" cc="UA" sponsor="Campus Networks" id="2558" url2="http://test.campus.rv.ua/speedtest/upload.php" host="test.campus-rv.net:8080"/><server url="http://speedtest-rivne.airbites.net.ua/speedtest/upload.php" lat="50.6167" lon="26.2500" name="Rivne" country="Ukraine" cc="UA" sponsor="Airbites Ukraine" id="4658" url2="http://speedtest-rv.airbites.net.ua/speedtest/upload.php" host="speedtest-rivne.airbites.net.ua:8080"/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}