import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\?]*[PG]$|[\\?\\$].*\\$$";
final String string = "PPCG\n"
+ "?$\n"
+ "^P\n"
+ "?$\n"
+ "^[P^]P\n"
+ "[^?][PG]$\n"
+ "(?<!\\\\..)(?!]).$\n"
+ "^[\\w^]*$|!|]P|G]\\$$\n"
+ "!|[^?]P(CG|G..)?$\n"
+ "[^])]\\$|^\\^?P|P.\\].$\n"
+ "([.$?]|G\\])\\$$|^\\^?P|\\]P$\n"
+ "([P.$?]\\$|[]^]P|G\\]\\$|CG)$\n\n"
+ "[PPCG]\n"
+ "^[P\\^]\n"
+ "[^\\]]$\n"
+ "^\\^?P\n"
+ "[^?][PG]$|<|PG\n"
+ "^[^\\\\|]*(\\\\\\\\)+[^\\\\|]*[^\\]]$\n"
+ "^(.{,4}|.{9}|.{16,19}|.{5}P)$\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}