package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([^*]*)(?:$|\*.*?page\s*\d+\s*of\s*\d+)`)
var str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit. Phasellus venenatis ultricies pulvinar. Sed sed faucibus orci, at pharetra ex. Donec lacinia massa sed nunc aliquet ultricies. Duis suscipit, purus et commodo auctor, leo tellus molestie dui, quis porttitor orci nulla eu diam. Cras efficitur mauris dignissim, lobortis purus id, luctus erat. Vestibulum a mollis ante, id viverra libero. Vestibulum gravida enim non dignissim varius. Sed velit sapien, blandit quis imperdiet a, vulputate nec turpis. In hac habitasse platea dictumst.\n*TEST06499YGOV 297296+10*\nMorbi auctor fringilla pulvinar. Donec mattis arcu ac metus scelerisque\n 2090 12/15 Page 1 of 3Sed faucibus tempor ex, euismod consequat diam tincidunt sed. Donec sagittis aliquam dolor vitae faucibus. Ut lobortis magna risus, ut sagittis sem convallis eget. Nulla tellus lectus, aliquet ut lacinia quis, sagittis in odio. Ut egestas, sapien id ultrices aliquet, urna mi rutrum nunc, scelerisque rhoncus nulla sem eget risus. Sed eget mollis ante. Vivamus et malesuada neque, ac finibus lectus. Vestibulum consequat purus sit amet elit dapibus gravida. Phasellus in lorem vestibulum, sagittis lacus nec, hendrerit velit. Praesent sapien eros, pharetra eu magna quis, aliquam vestibulum mi. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Donec at aliquet felis, vitae semper ante. Pellentesque aliquam, nisl vitae ullamcorper posuere, lorem neque placerat elit, non hendrerit eros lectus nec quam. Praesent sollicitudin tempor tortor. Ut tellus massa, viverra sed iaculis nec, egestas gravida felis. Nam fringilla placerat volutpat.\n*TEST06499YGOV 297296+10*\nMorbi auctor fringilla pulvinar. Donec mattis arcu ac metus scelerisque\n 2090 12/15 Page 2 of 3Duis ullamcorper, nunc id aliquet luctus, arcu justo tristique nisl, a viverra libero odio sed massa. Duis nec nibh eu risus feugiat dignissim sit amet eu orci. Aliquam malesuada tristique augue non venenatis. Sed in viverra mauris. Suspendisse eu leo non augue molestie tempus. Donec ultrices facilisis turpis, vel fringilla mauris semper ut. Aliquam ullamcorper ante vitae porttitor ultricies. Nullam et consectetur justo. Vestibulum non ullamcorper ex`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}