$re = '/(?i).*(This is a test).*/m';
$str = 'this is a test
THIS IS A TEST
THIS is A tEsT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);