$re = '/$(?:end of line){0}/m';
$str = 'line 1
line 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);