$re = '/(^|^[^:\n]+:\/\/|[^.\n]+\.)hello\.net(?:\/.*)?$/m';
$str = 'http://hello.net
https://hello.net
http://www.hello.net
https://www.hello.net
http://domain.hello.net
https://solutions.hello.net
hello.net
www.hello.net
hello.net.domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);