re = /^(?:\w+:\/\/)?(?:[^\/.\n]+\.)?hello\.net(?:\/.*)?$/m
str = 'http://hello.net
https://hello.net
http://www.hello.net
https://www.hello.net
http://domain.hello.net
https://solutions.hello.net
hello.net
www.hello.net
hello.net.domain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end