package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([01][0-9]|[2][0-3]):([0-5][0-9])`)
var str = `12:59`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}