$re = '/(?<=href=\")[^\?]+\?page=(\d)(?=\")/';
$str = '<a class="next_page" href="/quotes/tag/fun?page=2" rel="next">next ยป</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);