$re = '/\b[^\W_]+/m';
$str = 'home/products/product_name_1/details/some_options';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);