import Foundation
let pattern = #"(?=\n\s*\n|\z)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Iste mollitia similique, blanditiis quisquam suscipit optio quam culpa odit ad magni sunt officiis, recusandae deleniti alias, natus commodi sed expedita labore.
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Quae distinctio atque, eos quo. Autem commodi dicta, numquam natus illum recusandae quos! Veniam nulla et temporibus necessitatibus vero recusandae tempora saepe!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{id}}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)