$re = '/\bi(\'|\b\s+a)m \b\d{1,2}(?:\.\d+)?\b(?!\s*%)/m';
$str = 'i\'m 92 in';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);