$re = '/(INSERT INTO(?s:.)*?VALUES(?s:.)*?\))/m';
$str = ' ...
SOME COMMAND TEXT
SOME COMMAND TEXT
INSERT INTO table (CAMPO 1, CAMPO 2)
VALUES (1, 2)
SOME COMMAND TEXT
INSERT INTO table (CAMPO 1, CAMPO 2) VALUES (1, 2)
SOME COMMAND TEXT
INSERT INTO table (CAMPO 1, CAMPO 2) VALUES (1, 2)
SOME COMMAND TEXT
INSERT INTO table VALUES (1, 1, 1, 1, 1);
INSERT INTO table VALUES (1, 1, 1, 1, 1) ;
INSERT INTO table VALUES (1, 1, 1, 1, 1);
INSERT INTO table VALUES (1, 1, 1, 1, 1) ;
SOME COMMAND TEXT
SOME COMMAND TEXT
...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);